Home Hacking google Researcher Found Security Threats in Palo Alto Networks

google Researcher Found Security Threats in Palo Alto Networks

3 min read
0
0

google Researcher Found Security Threats in Palo Alto Networks

A google researcher who works in Project Zero, Ormandy has identified a few vulnerabilities in Palo Alto Networks’ PAN-OS operating system. Through these flaws, an attacker can execute arbitrary code with root privileges if he wants to.

The researcher reported a total of three security flaws to Palo Alto Networks in August. The most serious of them, rated critical and tracked as CVE-2016-9150, is related to how the PAN-OS web management server handles a buffer overflow. An attacker with network access to the management interface can leverage this weakness to execute arbitrary code or cause a denial-of-service (DoS) condition.

The Google researcher pointed out that PAN-OS uses a modified version of the Appweb 3 embedded web server, which reached end-of-life in 2012 and no longer receives security updates.

While this vulnerability only allows remote code execution as an unprivileged user, Ormandy discovered two local privilege escalation bugs that can be exploited to obtain root permissions. These flaws are tracked as CVE-2016-9151.

“Palo Alto Networks firewalls do not properly validate certain environment variables which can potentially allow executing code with higher privileges,” the vendor said in an advisory.

Palo Alto Networks initially told the Google researcher that one of these privilege escalations had already been patched, but Ormandy quickly found a way to bypass the fix.

The vulnerabilities affect PAN-OS 5.0.19 and earlier, PAN-OS 5.1.12 and earlier, PAN-OS 6.0.14 and earlier, PAN-OS 6.1.14 and earlier, PAN-OS 7.0.10 and earlier, and PAN-OS 7.1.5 and earlier. The issues were addressed last week with the release of PAN-OS versions 5.0.20, 5.1.13, 6.0.15, 6.1.15, 7.0.11 and 7.1.6.

The updates also resolve a post-authentication vulnerability that can allow XPath manipulation and an OpenSSH flaw. Both of these issues have been rated “low severity.”

Ormandy has discovered serious vulnerabilities in products from several security solutions providers, including Symantec, FireEye, Trend Micro, Comodo, Kaspersky Lab, AVG and Avast.

Load More Related Articles
Load More In Hacking

Leave a Reply

Your email address will not be published. Required fields are marked *

Check Also

New Cold Boot Attacks Can Evade Current Mitigations

New Cold Boot Attacks Can Evade Current Mitigations Many people tend to put laptops to ‘Sl…